
Tutorial for ETABS V9 

3-D Modelling and Dynamic Analysis of a RC Core Wall
 

This short manual provides step-by-step instructions to model and 
dynamically analyze the RC core wall seismically designed in the Third 
Edition of the Concrete Design Handbook (CDH) at Section 11.5 of Part II. 
The figure below shows the model resulting from these instructions (colours 
may be different). 
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Step-By-Step Procedure 

1. Click File > New Model… 

2. In the form New Model Initialization, click No. 

3. In the form Building Plan Grid System and Story Data Definition, 
set the parameters Grid Dimensions (Plan), Story Dimensions and 
Units as shown in the figure below. Once set, click on Edit Grid… 

 

 

 

4. The form Define Grid Data appears. By default, ETABS defines four X-
Grids numbered from A to D and four Y-Grids numbered from 1 to 4. 
From this default, one X-Grid will be added and one Y-Grid will be 
deleted for the present example. 
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To add a grid line, simply enter a Grid ID and an Ordinate in the line 
below those already defined. At this new line, double click on the empty 
spaces associated to Line Type, Visibility and Bubble Loc. to define 
these parameters. To delete a grid line, click on the number of the grid 
line to be deleted to highlight the line. Leave the mouse cursor over the 
highlighted line, right-click on your mouse and then select Delete in the 
form that appears. 

 

In this example, the grid data will be defined as shown below (the thick 
lines represent the wall cross-section to be defined later). 

 

 

 

Based on the above figure, set the form Define Grid Data as shown in 
the figure below. Once set, click OK. Click OK to close the other form. 
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The figure below shows the result of the grid data definition. 
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5. Save your ETABS file by clicking File > Save… Prior to saving, make 
sure that the units are still in kN-m (see the lower right corner of the 
main window, as shown in the above figure) 

6. Definition of the material properties. Click Define > Material 
Properties…  Three materials are already defined in ETABS: CONC, for 
concrete, STEEL and OTHER. The material CONC will be modified for 
the example. Highlight CONC and click Modify/Show Material… Set 
the material properties as follows, click OK once completed and OK 
again to close the form Define Materials: 

 
Etabs_Tutorial_Wall.doc   5 of 12 



Tutorial for ETABS V9 

3-D Modelling and Dynamic Analysis of a RC Core Wall
 

 

 

7. Definition of the member sections. Both the wall and the coupling beam 
members of the core wall could be modelled with plane elements. 
However, for the example, the wall members will be modelled with 
plane elements while the coupling beam members will be modelled with 
beam elements. 

 

To define sectional beam properties, click Define > Frame Sections… 
Several default frame sections are defined in ETABS. For the example, a 
new frame section is defined. In the form Define Frame Properties, 
click the drop-down list that reads Add I/Wide Flange in the Click To 
area. Scroll down the resulting list until Add Rectangular and then 
click on it. In the form Rectangular Section, give a section name, 
select the appropriate material and enter the dimensions of the beam 
section. Click Set Modifiers… and enter the ratios used to make 
allowance for cracking. Click OK three times to close all forms. 

 

To define sectional wall properties, click Define > Wall/Slab/deck 
Sections… Highlight Wall1 in the Sections area of the form Define 
Wall/Slab/deck Sections and then click Modify Show/Section… in 
the Click To area. In the form Wall/Slab Section, give a section 
name, select the appropriate material and enter the thickness in 
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membrane and bending of the wall section. Click Set Modifiers… and 
enter the ratios used to make allowance for cracking. Click OK three 
times to close all forms. 

 

8. Prior to modelling members, make sure that the left window Plan View 
is at STORY13. If not, click View > Set Plan View…  Highlight 
STORY13 and click OK. In the right window 3-D View, the top of the 
upper storey should be highlighted, indicating the plan view showed in 
the left window. 

9. At the bottom of the main window, click the drop-down list that reads 
One Story and select All Stories. This command enables to apply at all 
stories what it is performed at the working story. This command is 
useful for this example because the wall cross-section is uniform over 
the entire height of the wall. Actually, with this command activated, the 
structural members generated at one story will be automatically 
generated at all stories. 

10. In order to readily visualize the members generated, click View > Set 
Building View Options… In the associated form, check boxes as 
shown in the figure below. Click OK to close the form. 
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11. Modelling of the structural members. First the wall members are 
generated. Click Draw > Draw Area Objects > Draw Walls (Plan). 
The form Properties of Object appears.  Use the default values in this 
form but make sure that the name of the wall section defined previously 
is assigned to Property. In the Plan View – STORY13, select with the 
mouse cursor the grid points such to draw two unconnected C-shaped 
sections, as shown in the figure below. When one section is drawn, click 
the right button of the mouse to stop drawing the section. When both 
sections are drawn, press the ESC button to exit the Draw Walls 
command. 

 

Secondly the coupling beam members are generated. Click Draw > 
Draw Line Objects > Create Lines in Region or at Clicks (Plan, 
Elev, 3D). The form Properties of Object appears. In this form, 
assign to Property the coupling beam section previously defined by 
clicking on the default property and selecting the desired one. For the 
other parameters in this form, use the default values. In the Plan View 
– STORY13, move the mouse cursor over the line segments B-C and C-
D of the grid line 1 and click on both. This generates coupling beams at 
all stories along grid line 1. Repeat the same steps for grid line 3. Once 
completed, press the ESC button to exit the Draw Line command. 

 

The figure below shows the resulting wall structure. 
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12. Creation of a point object at the center of the whole wall section. Click 
Draw > Draw Point Objects. In the window Plan View – STORY13, 
select with the mouse cursor the grid point C2. Once completed, press 
the ESC button to exit the Draw Point command. 

13. Generation of diaphragms. Click Select > At Pointer/In Window. In 
the window Plan View – STORY13, select with the mouse cursor all 
grid points by making a selection box enclosing the whole wall section. 
Click Assign > Joint Point > Diaphragms… Highlight the diaphragm 
D1 and click OK. A diaphragm should appear at each story. 

14. Removing of the beam elements at the base. Click View > Set Plan 
View… Select the plan level BASE and click OK. At the bottom of the 
main window, click the drop-down list that reads All Stories and select 
One Story. Prior to selecting beam elements, clear any possible 
undesired selections by clicking Select > Clear Selection. In the 
window Plan View – BASE, select with the mouse cursor all beam 
elements by enclosing them with a selection box. Once selected, click 
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the right button of the mouse and select Delete Selected Objects. Do 
the same operation to delete the point object at grid point C2. 

15. Fixing the wall model at its base. In the window Plan View – BASE, 
select with the mouse cursor all grid points displayed (make sure that 
the selection is for One story only). Click Assign > Joint Point > 
Restraints (Supports)… In the form Assign Restraints, check all 
check boxes and click OK to close the form. 

16. Mass definition. Different ways are possible to define mass. In this 
example, the mass is defined from loads, which are the seismic weights 
of the building. Consequently, a static load case must first be defined. 
Click Define > Static Load Cases… In the Loads area of the form 
Define Static Load Case Names, type a name (for instance WEIGHT) 
in the Load field, select DEAD in the Type field and set Self Weight 
Multiplier to 0. In the Click To area of the form, click Add New Load. 
Delete the default load cases DEAD and LIVE by highlighting them and 
clicking Delete Load in the Click To area. Once completed, click OK to 
close the form. Click Define > Mass Source… In the form Define 
Mass Source, select From Loads in the Mass Definition area and 
click Add in the Define Mass Multiplier for Loads area. Leave the 
check boxes checked. Click OK to close the form. 

 

Click View > Set Plan View… Select the plan level STORY12 and click 
OK. In the window Plan View – STORY12, select with the mouse 
cursor the grid point C2 (make sure that the selection is for One story 
only). Click Assign > Joint Point/Loads > Force… In the form Point 
Forces, set the parameters as shown in the figure below (Note: the 
Load Case Name is that defined previously). Click OK to close the 
form. Repeat these steps for all stories where a seismic weight is given 
in the CDH. 
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In order to verify the force assigned at a point object, simply move the 
mouse cursor over this object to highlight it and click on the right button 
of the mouse. A Point Information form appears. Select the tab 
Loads. Click OK to close the form. 

 

17. Definition of the design acceleration response spectrum. Click Define > 
Response Spectrum Functions… In the Click To area of the form, 
click the drop-down list and select Add User Spectrum. In the form 
Response Spectrum Function Definition, type a Function Name 
and enter in the Define Function area the period and design spectral 
acceleration values (in fraction of gravity) given in the CDH. Once 
completed, click OK and OK again to close the form. 

18. Definition of two response spectrum cases, one for each design 
earthquake loading direction. Click Define > Response Spectrum 
Cases… In the form, click Add New Spectrum… In the form 
Response Spectrum Case Data, type a Spectrum Case Name. In 
the Input Response Spectra area, click on the drop-down list 
Function of the direction U1 (Global X) to select the spectrum function 
previously defined and enter 9.81 as Scale Factor (make sure that 
Units is still kN-m). Click OK. Repeat the previous steps to define the 
response spectrum case in the orthogonal direction. 

19. Definition of a pier entity to get wall forces in an appropriate format for 
design. At the bottom of the main window, click the drop-down list that 
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reads One Story and select All Stories. Click View > Set Plan View… 
Select the plan level STORY13 and click OK. In the window Plan View 
– STORY13, select with the mouse cursor one of the two C-shaped wall 
sections. Click Assign > Shell/Area > Pier Label… In the Wall Piers 
area of the form Pier Names, type a name of pier. Click Add New 
Name in the Click To area.  Leave the new name highlighted and click 
OK to close the form. Repeat these steps to define a pier entity for the 
other C-shaped wall section. 

20. Modelling verification of the whole wall model. Click Analyze > Check 
Model… Check all boxes in the form Check Model and click OK. A 
Warning form appears. If no issue/problem is detected, the message 
“Model has been checked, No warning messages” appears in this 
form. Close the form. Otherwise, fix the detected problems. 

21. Analysis setting. Click Analyze > Set Analysis Options… In the form 
Analysis Options, select Full 3D, check only Dynamic Analysis and 
click on Set Dynamic Parameters… In the form Dynamic Analysis 
Parameters, enter the number of modes to be calculated, set Type of 
Analysis to Eigenvectors and click OK. Click OK to close the form 
Analysis Options. 

22. Run the requested analysis. Prior to running analysis, make sure that 
Units is kN-m and save the model. Click Analyze > Run Analysis. 

23. Displaying analysis results. Once the dynamic analysis is completed, set 
first Units to kN-m if necessary. To display results, click Display and 
select the desired results. 

 

ETABS enables to display results in tables that can be copied and pasted 
in worksheets of a calculator, such as Microsoft Excel. To display these 
tables, click Display > Show Tables… Select the desired results and 
load cases, and click OK. 


